Login Failure for Salt Dashboard (US Tenants) – SSO and Username/Password Authentication errors

Incident Report for Salt Security

Resolved

This incident has been resolved.
Posted May 29, 2025 - 23:49 UTC

Investigating

We are currently experiencing an issue affecting user authentication on the Salt Dashboard for US based tenants (e.g. https://[company_name].secured-api.com/login).

Symptoms:
- Users may encounter a 500 Internal Server Error when attempting to log in via SSO with the error "No SSO service is configured for your company"
- When using username/password login, users may see an “Incorrect email or password” message

Current Status:
Our Platform and Engineering teams are actively investigating the root cause. We are treating this as a major outage and updates will be provided as we learn more.

We apologize for the inconvenience and appreciate your patience as we work to resolve this issue.
Posted May 29, 2025 - 21:46 UTC
This incident affected: Web interface (Customer dashboard).